Quantcast

strange problem foxpro run exe on win 10

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

strange problem foxpro run exe on win 10

Samba - General mailing list
hi,

one of my customers still use old foxpro
we migrate from samba 3.6.3 to samba 4.1.17
and everything seems to be alright

foxpro is using command "run" to starts external program and when I star
for example Wordpad by "run wordpad" I get Access denied
but when I directly run worpad, then everything runs ok
And this behavior appears only on Win7 - Win10 and not on WinXp
I set linux rights to 7777 to be sure, and i can write to folder.


Where should i start looking for problem (logs ...)?
thanks mk


--
Michal Kavan
+420 776 291 782
+420 499 315 322


---
Tato zpráva byla zkontrolována na viry programem Avast Antivirus.
https://www.avast.com/antivirus


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
On Sun, 19 Mar 2017 20:16:55 +0100
Michal Kavan via samba <[hidden email]> wrote:

>
> Where should i start looking for problem (logs ...)?
> thanks mk
>

I good place to start would be posting your smb.conf, by doing this we
can see how you are running Samba and advise if any alterations to it
are required.

Rowland
 


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
here it is
----
[global]
         workgroup = all
         server string = Samba Server
         load printers = no
         security = user
         max log size = 200
         time server = yes
         local master = no
         os level = 10
         log file = /var/log/samba/log.%I
         printcap name = /dev/null
         netbios name = new07server-fst
#       log level = 2 acls:10
         log level = 10
#       null passwords = yes
         encrypt passwords = yes
         domain master = no
         map to guest = Bad Password

         domain logons = no
         preferred master = no
         follow symlinks = yes
         guest account = samba_guest
         socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

         full_audit:success = connect disconnect mkdir rmdir rename unlink
         #full_audit:success = connect disconnect mkdir rmdir rename
unlink pread read
         full_audit:priority = notice
         full_audit:facility = local5
         full_audit:prefix = %u |%I  %m| %S
         full_audit:failure = connect


#full_audit:success = connect disconnect opendir mkdir rmdir closedir
open close read pread write pwrite sendfile rename unlink chmod
#fchmod chown fchown chdir ftruncate lock symlink readlink link mknod
realpath

         #acl map full control = False
         dos filemode = yes
         acl allow execute always = yes

[data]
path = /home/samba/data
comment = aplikace mirror md3
public = yes
writeable = yes
create mask = 7777
directory mask = 7777
#guest only = yes
vfs object = full_audit
acl allow execute always = yes
browseable =yes

---

Michal Kavan
+420 776 291 782
+420 499 315 322

Dne 2017/03/19 v 20:51 Rowland Penny napsal(a):

> On Sun, 19 Mar 2017 20:16:55 +0100
> Michal Kavan via samba <[hidden email]> wrote:
>
>> Where should i start looking for problem (logs ...)?
>> thanks mk
>>
> I good place to start would be posting your smb.conf, by doing this we
> can see how you are running Samba and advise if any alterations to it
> are required.
>
> Rowland
>  
>


---
Tato zpráva byla zkontrolována na viry programem Avast Antivirus.
https://www.avast.com/antivirus


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
On Sun, 19 Mar 2017 21:02:23 +0100
Michal Kavan <[hidden email]> wrote:

> here it is
> ----
> [global]
>          workgroup = all
>          server string = Samba Server
>          load printers = no
>          security = user
>          max log size = 200
>          time server = yes
>          local master = no
>          os level = 10
>          log file = /var/log/samba/log.%I
>          printcap name = /dev/null
>          netbios name = new07server-fst
> #       log level = 2 acls:10
>          log level = 10
> #       null passwords = yes
>          encrypt passwords = yes
>          domain master = no
>          map to guest = Bad Password
>
>          domain logons = no
>          preferred master = no
>          follow symlinks = yes
>          guest account = samba_guest
>          socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
>
>          full_audit:success = connect disconnect mkdir rmdir rename
> unlink #full_audit:success = connect disconnect mkdir rmdir rename
> unlink pread read
>          full_audit:priority = notice
>          full_audit:facility = local5
>          full_audit:prefix = %u |%I  %m| %S
>          full_audit:failure = connect
>
>
> #full_audit:success = connect disconnect opendir mkdir rmdir closedir
> open close read pread write pwrite sendfile rename unlink chmod
> #fchmod chown fchown chdir ftruncate lock symlink readlink link mknod
> realpath
>
>          #acl map full control = False
>          dos filemode = yes
>          acl allow execute always = yes
>
> [data]
> path = /home/samba/data
> comment = aplikace mirror md3
> public = yes
> writeable = yes
> create mask = 7777
> directory mask = 7777
> #guest only = yes
> vfs object = full_audit
> acl allow execute always = yes
> browseable =yes
>
> ---
>

The only possible problem I can see there (apart from the lines
that are default settings etc) is these lines:

create mask = 7777
directory mask = 7777

'7777' too many 7s, probably should be '0777'

I take it that all users connect as 'guest users', does the guest user
have permission to run the programs you want to run ?

What OS is this and is it possible to upgrade to a later version of
Samba ?
All versions of Samba before 4.4.0 are EOL as far as Samba is
concerned, so if your problem is specific to the 4.1.x series, it will
probably never get fixed.

Rowland

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
Dne 2017/03/19 v 21:29 Rowland Penny via samba napsal(a):

> On Sun, 19 Mar 2017 21:02:23 +0100
> Michal Kavan <[hidden email]> wrote:
>
>> here it is
>> ----
>> [global]
>>           workgroup = all
>>           server string = Samba Server
>>           load printers = no
>>           security = user
>>           max log size = 200
>>           time server = yes
>>           local master = no
>>           os level = 10
>>           log file = /var/log/samba/log.%I
>>           printcap name = /dev/null
>>           netbios name = new07server-fst
>> #       log level = 2 acls:10
>>           log level = 10
>> #       null passwords = yes
>>           encrypt passwords = yes
>>           domain master = no
>>           map to guest = Bad Password
>>
>>           domain logons = no
>>           preferred master = no
>>           follow symlinks = yes
>>           guest account = samba_guest
>>           socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
>>
>>           full_audit:success = connect disconnect mkdir rmdir rename
>> unlink #full_audit:success = connect disconnect mkdir rmdir rename
>> unlink pread read
>>           full_audit:priority = notice
>>           full_audit:facility = local5
>>           full_audit:prefix = %u |%I  %m| %S
>>           full_audit:failure = connect
>>
>>
>> #full_audit:success = connect disconnect opendir mkdir rmdir closedir
>> open close read pread write pwrite sendfile rename unlink chmod
>> #fchmod chown fchown chdir ftruncate lock symlink readlink link mknod
>> realpath
>>
>>           #acl map full control = False
>>           dos filemode = yes
>>           acl allow execute always = yes
>>
>> [data]
>> path = /home/samba/data
>> comment = aplikace mirror md3
>> public = yes
>> writeable = yes
>> create mask = 7777
>> directory mask = 7777
>> #guest only = yes
>> vfs object = full_audit
>> acl allow execute always = yes
>> browseable =yes
>>
>> ---
>>
> The only possible problem I can see there (apart from the lines
> that are default settings etc) is these lines:
>
> create mask = 7777
> directory mask = 7777
>
> '7777' too many 7s, probably should be '0777'
>
> I take it that all users connect as 'guest users', does the guest user
> have permission to run the programs you want to run ?
>
> What OS is this and is it possible to upgrade to a later version of
> Samba ?
> All versions of Samba before 4.4.0 are EOL as far as Samba is
> concerned, so if your problem is specific to the 4.1.x series, it will
> probably never get fixed.
>
> Rowland
>
os is ubuntu 16.04. (i have same behavior also on samba 4.3.11, so i
think thats linked with change from samba 3.6.x >> to 4.xx)
yes, guest user (samba_guest) have permision to run (all files are set
to 777) and i can run program directly and also from win xp, but no from
foxprol on win 7/win10

7777 in create mas was despered try to set also uuid,gid and sticky bit ;]

mk


--
Michal Kavan
+420 776 291 782
+420 499 315 322


---
Tato zpráva byla zkontrolována na viry programem Avast Antivirus.
https://www.avast.com/antivirus


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
On Sun, 19 Mar 2017 21:49:28 +0100
Michal Kavan <[hidden email]> wrote:

> os is ubuntu 16.04. (i have same behavior also on samba 4.3.11, so i
> think thats linked with change from samba 3.6.x >> to 4.xx)
> yes, guest user (samba_guest) have permision to run (all files are
> set to 777) and i can run program directly and also from win xp, but
> no from foxprol on win 7/win10
>

Hmm, you can run the program directly
You can run the program from an XP client
You cannot run the program from a win 7 or 10 client

This says a Windows 7/10 problem to me, but you could try checking the
server & client max protocol with:


testparm -v | grep 'max protocol'

Rowland


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
In reply to this post by Samba - General mailing list
Am 19.03.2017 um 20:16 schrieb Michal Kavan via samba:

> foxpro is using command "run" to starts external program and when I star
> for example Wordpad by "run wordpad" I get Access denied

acl allow execute always = yes

--
der tom

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
On Sun, 19 Mar 2017 22:17:44 +0100
Thomas Bork via samba <[hidden email]> wrote:

> Am 19.03.2017 um 20:16 schrieb Michal Kavan via samba:
>
> > foxpro is using command "run" to starts external program and when I
> > star for example Wordpad by "run wordpad" I get Access denied
>
> acl allow execute always = yes
>

Ah, the line I missed seeing twice in his smb.conf LOL

Rowland

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
In reply to this post by Samba - General mailing list
Dne 2017/03/19 v 22:11 Rowland Penny via samba napsal(a):

> On Sun, 19 Mar 2017 21:49:28 +0100
> Michal Kavan <[hidden email]> wrote:
>
>> os is ubuntu 16.04. (i have same behavior also on samba 4.3.11, so i
>> think thats linked with change from samba 3.6.x >> to 4.xx)
>> yes, guest user (samba_guest) have permision to run (all files are
>> set to 777) and i can run program directly and also from win xp, but
>> no from foxprol on win 7/win10
>>
> Hmm, you can run the program directly
> You can run the program from an XP client
> You cannot run the program from a win 7 or 10 client
>
> This says a Windows 7/10 problem to me, but you could try checking the
> server & client max protocol with:
>
>
> testparm -v | grep 'max protocol'
>
> Rowland
>
>

yes, its looks like win7/10 problem (but only on samba 4.x) to me, but i
have no idea what to do (except downgrade to 3.6.x)


server max protocol = SMB3
client max protocol = NT1


mk


---
Tato zpráva byla zkontrolována na viry programem Avast Antivirus.
https://www.avast.com/antivirus


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
On Sun, 19 Mar 2017 23:23:58 +0100
Michal Kavan via samba <[hidden email]> wrote:

>
> yes, its looks like win7/10 problem (but only on samba 4.x) to me,
> but i have no idea what to do (except downgrade to 3.6.x)
>
>
> server max protocol = SMB3
> client max protocol = NT1
>

Try setting this in smb.conf:

client max protocol = default

Rowland

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
Dne 20.03.2017 v 10:05 Rowland Penny napsal(a):

> On Sun, 19 Mar 2017 23:23:58 +0100
> Michal Kavan via samba <[hidden email]> wrote:
>
>> yes, its looks like win7/10 problem (but only on samba 4.x) to me,
>> but i have no idea what to do (except downgrade to 3.6.x)
>>
>>
>> server max protocol = SMB3
>> client max protocol = NT1
>>
> Try setting this in smb.conf:
>
> client max protocol = default
>
> Rowland
when i set client max protocol = default
then testparm -v is the same

server max protocol = SMB3
client max protocol = NT1



--
Michal Kavan


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
In reply to this post by Samba - General mailing list
Dne 2017/03/20 v 10:05 Rowland Penny napsal(a):

> On Sun, 19 Mar 2017 23:23:58 +0100
> Michal Kavan via samba <[hidden email]> wrote:
>
>> yes, its looks like win7/10 problem (but only on samba 4.x) to me,
>> but i have no idea what to do (except downgrade to 3.6.x)
>>
>>
>> server max protocol = SMB3
>> client max protocol = NT1
>>
> Try setting this in smb.conf:
>
> client max protocol = default
>
> Rowland
ok, final sulution was
server max protocol = NT1
and now everything is ok


--
Michal Kavan
+420 776 291 782
+420 499 315 322


---
Tato zpráva byla zkontrolována na viry programem Avast Antivirus.
https://www.avast.com/antivirus


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
Am 21.03.2017 um 20:38 schrieb Michal Kavan via samba <[hidden email]>:
> ok, final sulution was
> server max protocol = NT1
> and now everything is ok

Exact same problem here with some other ancient program (emTeX).

Works only with
server max protocol = NT1

I wonder what happens if we try to switch to AD-DC.

--
Message sent from a mobile device, please excuse brevity and typos

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: strange problem foxpro run exe on win 10

Samba - General mailing list
Am 25.03.2017 um 18:10 schrieb Klaus Hartnegg via samba:
> Am 21.03.2017 um 20:38 schrieb Michal Kavan via samba <[hidden email]>:
>> ok, final sulution was
>> server max protocol = NT1
>> and now everything is ok
>
> Exact same problem here with some other ancient program (emTeX).
>
> Works only with
> server max protocol = NT1

Update:
This problem is gone in Samba version 4.5.8.

I removed the line from smb.conf, and emTeX still works.
Cannot test with Foxpro though.

Smbstatus now shows protocol version SMB2_10 for connections from Win7,
and protocol version SMB3_11 for connections from Win10.

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Loading...