samba4 with glusterfs

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

samba4 with glusterfs

Ulrich Schinzli
Hi Sambalist,

maybe someone with some glusterfs experience can help me.

I have a running samba4 installation here.
Now i tried to get glusterfs configured so I can use glusterfs as an
additional storagesystem.

The setup of glusterfs worked pretty easy. I tried multiple
configurations with up to 4 virtual machines (Virtual Box).
The bricks are xfs-filesystems.

Mounting glusterfs (mount -t glusterfs gluster01:/volume1
/samba/glusterfs -o acl) is working as well, but I have a strange error.
Trying to set the rights on that share /samba/glusterfs from windows is
not possible.

Gluster tells me following:
[2013-05-10 15:43:43.508988] E [posix.c:2583:posix_getxattr]
0-dfsvol01-posix: getxattr failed on /export/brick1/: user.DOSATTRIB (No
data available)

another error:
[2013-05-10 15:49:54.998621] E [posix.c:2583:posix_getxattr]
0-dfsvol01-posix: getxattr failed on /export/brick1/:
system.posix_acl_access (No data available)
[2013-05-10 15:49:55.028892] E [marker.c:2136:marker_removexattr_cbk]
0-dfsvol01-marker: No data available occurred while creating symlinks
[2013-05-10 15:49:55.028952] I
[server3_1-fops.c:738:server_removexattr_cbk] 0-dfsvol01-server: 127:
REMOVEXATTR / (00000000-0000-0000-0000-000000000001) ==> -1 (No data
available)


And it's right, there is no data in there... samba wants to write it...

I did a (in my opinion identical) setup on 2 virtualbox machines before.
There everything is working fine.

Trying to set xattrs in shell works fine, it works on the bricks (xfs)
and on the mounted glusterfs-volume (mount -t glusterfs ... -o acl ...
or without -o acl, doesnt matter). It
works perfect, no errors in logfile nothing. just setfattr -n user.test
-v test file.txt and thing is done... Prequesites for samba should be
given in that case....

System: Debian Wheezy
Brick fs: xfs (mounted with defaults)
gluster version: 3.3.1
gluster replica 2 (2 nodes)

Has someone any idea whats missing?

Kind regards
Uli
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Hisham Attar
have you tried mounting with user_xattr in addition to acl? I had to do
that when I was using glusterfs for sysvol replication


On Sat, May 11, 2013 at 12:00 AM, Ulrich Schinz <[hidden email]> wrote:

> Hi Sambalist,
>
> maybe someone with some glusterfs experience can help me.
>
> I have a running samba4 installation here.
> Now i tried to get glusterfs configured so I can use glusterfs as an
> additional storagesystem.
>
> The setup of glusterfs worked pretty easy. I tried multiple configurations
> with up to 4 virtual machines (Virtual Box).
> The bricks are xfs-filesystems.
>
> Mounting glusterfs (mount -t glusterfs gluster01:/volume1 /samba/glusterfs
> -o acl) is working as well, but I have a strange error.
> Trying to set the rights on that share /samba/glusterfs from windows is
> not possible.
>
> Gluster tells me following:
> [2013-05-10 15:43:43.508988] E [posix.c:2583:posix_getxattr]
> 0-dfsvol01-posix: getxattr failed on /export/brick1/: user.DOSATTRIB (No
> data available)
>
> another error:
> [2013-05-10 15:49:54.998621] E [posix.c:2583:posix_getxattr]
> 0-dfsvol01-posix: getxattr failed on /export/brick1/:
> system.posix_acl_access (No data available)
> [2013-05-10 15:49:55.028892] E [marker.c:2136:marker_**removexattr_cbk]
> 0-dfsvol01-marker: No data available occurred while creating symlinks
> [2013-05-10 15:49:55.028952] I [server3_1-fops.c:738:server_**removexattr_cbk]
> 0-dfsvol01-server: 127: REMOVEXATTR / (00000000-0000-0000-0000-**000000000001)
> ==> -1 (No data available)
>
>
> And it's right, there is no data in there... samba wants to write it...
>
> I did a (in my opinion identical) setup on 2 virtualbox machines before.
> There everything is working fine.
>
> Trying to set xattrs in shell works fine, it works on the bricks (xfs) and
> on the mounted glusterfs-volume (mount -t glusterfs ... -o acl ... or
> without -o acl, doesnt matter). It
> works perfect, no errors in logfile nothing. just setfattr -n user.test -v
> test file.txt and thing is done... Prequesites for samba should be given in
> that case....
>
> System: Debian Wheezy
> Brick fs: xfs (mounted with defaults)
> gluster version: 3.3.1
> gluster replica 2 (2 nodes)
>
> Has someone any idea whats missing?
>
> Kind regards
> Uli
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/**mailman/options/samba<https://lists.samba.org/mailman/options/samba>
>
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Ulrich Schinzli
Am 10.05.2013 16:15, schrieb Hisham Attar:
> have you tried mounting with user_xattr in addition to acl? I had to
> do that when I was using glusterfs for sysvol replication
>
As far as i know xfs is mounted with user_xattr, isn't it? So the bricks
should work well...
And for glusterfs there is only the option acl, not user_xattr option...
or am I wrong?

kind regards
uli
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Hisham Attar
you can mount glusterfs with user_xattr, I had to do that otherwise I
couldnt rsync extended attributes to the mount point


On Sat, May 11, 2013 at 1:00 AM, Ulrich Schinz <[hidden email]> wrote:

> Am 10.05.2013 16:15, schrieb Hisham Attar:
>
>> have you tried mounting with user_xattr in addition to acl? I had to do
>> that when I was using glusterfs for sysvol replication
>>
>>  As far as i know xfs is mounted with user_xattr, isn't it? So the bricks
> should work well...
> And for glusterfs there is only the option acl, not user_xattr option...
> or am I wrong?
>
> kind regards
> uli
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/**mailman/options/samba<https://lists.samba.org/mailman/options/samba>
>
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Ulrich Schinzli
hmmm, ok, I'm not able to find an option... but I think it's enabled by
default. If it wouldn't be enabled, I couldnt setfattr.
And I can setfattr -n user.test -v test MOUNTEDGLUSTERFSDIR without any
problems.... Only using windows -> samba leads to the problems...

maybe you can give me a hint with that user_xattr option... i use

mount -t glusterfs -o acl gluster01:/vol01 /samba/glusterfs

-o acl,user_xattr is not working, -o acl,fuse-opt=user_xattr also not
working....

kind regards uli


Am 10.05.2013 17:15, schrieb Hisham Attar:
> you can mount glusterfs with user_xattr, I had to do that otherwise I
> couldnt rsync extended attributes to the mount point
>

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Hisham Attar
for mine to work (under ubuntu) I had to mount with the options at the end
or it didnt work
mount -t glusterfs gluster01:/vol01/samba/glusterfs -o acl,user_xattr


On Sat, May 11, 2013 at 1:59 AM, Ulrich Schinz <[hidden email]> wrote:

> hmmm, ok, I'm not able to find an option... but I think it's enabled by
> default. If it wouldn't be enabled, I couldnt setfattr.
> And I can setfattr -n user.test -v test MOUNTEDGLUSTERFSDIR without any
> problems.... Only using windows -> samba leads to the problems...
>
> maybe you can give me a hint with that user_xattr option... i use
>
> mount -t glusterfs -o acl gluster01:/vol01 /samba/glusterfs
>
> -o acl,user_xattr is not working, -o acl,fuse-opt=user_xattr also not
> working....
>
> kind regards uli
>
>
> Am 10.05.2013 17:15, schrieb Hisham Attar:
>
>  you can mount glusterfs with user_xattr, I had to do that otherwise I
>> couldnt rsync extended attributes to the mount point
>>
>>
>
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Ulrich Schinzli
Am 11.05.2013 03:31, schrieb Hisham Attar:
> for mine to work (under ubuntu) I had to mount with the options at the
> end or it didnt work
> mount -t glusterfs gluster01:/vol01/samba/glusterfs -o acl,user_xattr
>
ah ok, maybe in earlier versions... for now it's an unkonwn option...

mount -t glusterfs sba-gluster01.intern.ksfh.de:/dfsvol01
/samba/glusterfs/ -o acl,user_xattr
unknown option user_xattr (ignored)


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
wil
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

wil
Ulrich Schinz <uli <at> schinz.de> writes:

>
> Am 11.05.2013 03:31, schrieb Hisham Attar:
> > for mine to work (under ubuntu) I had to mount with the options at the
> > end or it didnt work
> > mount -t glusterfs gluster01:/vol01/samba/glusterfs -o acl,user_xattr
> >
> ah ok, maybe in earlier versions... for now it's an unkonwn option...
>
> mount -t glusterfs sba-gluster01.intern.ksfh.de:/dfsvol01
> /samba/glusterfs/ -o acl,user_xattr
> unknown option user_xattr (ignored)
>

the option does appear to be there but it is either miss-named or doesn't
have an appropriate alias setup

glusterfs --help | grep -i attr

correct option name appears to be selinux

you could modify the mount script...
nano /sbin/mount.glusterfs

I can confirm this option doesn't appear to be in glusterfs 3.2.5 built on
Jan 31 2012 either as user_xattr or selinux

the operation of mount.glusterfs appears to be buggy when issued user_xattr
option - the log in /var/log/gluster/mnt.... indicates its trying to resolve
it as a host name

options are only specified after the volume when using the mount.glusterfs
script directly...
Usage:  mount.glusterfs <volumeserver>:<volumeid/volumeport> -o <options>
<mountpoint>

I believe when working directly with mount it's more normal to do as per man
entry....
mount [-fnrsvw] [-t vfstype] [-o options] device dir






--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: samba4 with glusterfs

Mueller
It is also missing in glusterfs 3.4!
Just setup samba4 with glusterfs on centos 6.4. The same error.
Only the acl option is working. A work around to see the extended acls from
windows is to set the volume stat-prefetch off.

Greetings
Daniel

-----------------------------------------------
EDV Daniel Müller

Leitung EDV
Tropenklinik Paul-Lechler-Krankenhaus
Paul-Lechler-Str. 24
72076 Tübingen

Tel.: 07071/206-463, Fax: 07071/206-499
eMail: [hidden email]
Internet: www.tropenklinik.de
-----------------------------------------------
-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im
Auftrag von wil
Gesendet: Mittwoch, 25. September 2013 01:58
An: [hidden email]
Betreff: Re: [Samba] samba4 with glusterfs

Ulrich Schinz <uli <at> schinz.de> writes:

>
> Am 11.05.2013 03:31, schrieb Hisham Attar:
> > for mine to work (under ubuntu) I had to mount with the options at
> > the end or it didnt work mount -t glusterfs
> > gluster01:/vol01/samba/glusterfs -o acl,user_xattr
> >
> ah ok, maybe in earlier versions... for now it's an unkonwn option...
>
> mount -t glusterfs sba-gluster01.intern.ksfh.de:/dfsvol01
> /samba/glusterfs/ -o acl,user_xattr
> unknown option user_xattr (ignored)
>

the option does appear to be there but it is either miss-named or doesn't
have an appropriate alias setup

glusterfs --help | grep -i attr

correct option name appears to be selinux

you could modify the mount script...
nano /sbin/mount.glusterfs

I can confirm this option doesn't appear to be in glusterfs 3.2.5 built on
Jan 31 2012 either as user_xattr or selinux

the operation of mount.glusterfs appears to be buggy when issued user_xattr
option - the log in /var/log/gluster/mnt.... indicates its trying to resolve
it as a host name

options are only specified after the volume when using the mount.glusterfs
script directly...
Usage:  mount.glusterfs <volumeserver>:<volumeid/volumeport> -o <options>
<mountpoint>

I believe when working directly with mount it's more normal to do as per man
entry....
mount [-fnrsvw] [-t vfstype] [-o options] device dir






--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba