robocopy from samba stalls

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

robocopy from samba stalls

Samba - General mailing list
Hello there.

I'm consistently running into trouble using robocopy to copy a large
directory structure, with some 50000 files, from a samba share to a local
windows clients.

I'm using packaged 4.6.2 samba, on Centos 7, running on as KVM VMS.  Both
machines I am running exhibit the following behaviour:

- I want to copy a large folder structure with 50000 files.
robocopy /E \\sambaserver\folder  d:\localfolder

After about 20 minutes, copying stalls in various places, with the client
unable to read file properties, with messages such as
"unable to access file properties of \\sambaserver\folder\a\b\foo.txt"
retrying

The session then is stuck.  the server is idle.  Browsing to the folder
shows the file to be in place.
Restarting the session will cause a similar error to occur, but on some
other file, after a similar amount of time.

Copying the same data from a real windows machine does not have this
problem, and takes about 40min in total.

This is my samba configuration.  Is anyone else experiencing anything
similar?

[global]
workgroup = WORKGROUP
server string = Samba Server %v
netbios name = sheeran
security = user
map to guest = bad user
dns proxy = no
#allow insecure wide links = yes

# performance options
socket options = TCP_NODELAY IPTOS_LOWDELAY
strict locking = No
min receivefile size = 16384
use sendfile = Yes
aio read size = 16384
aio write size = 16384


#============================ Share Definitions
==============================

[public]
path = /home/samba/public
#follow symlinks = yes
#wide links = yes
browsable =yes
writable = yes
guest ok = yes
read only = no



--
Kv,
Kristján Valur Jónsson, RVX
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba