login failures when using --authentication-file

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

login failures when using --authentication-file

Samba - samba-technical mailing list
Hello,

I am a new bee to Samba, when I tried to  login manually from my Linux server to windows server connecting successfully, but when I use authentication  file I am getting following error. Please advice?

session setup failed: NT_STATUS_LOGON_FAILURE

[root@****** _temp]# smbclient  //pc-fp1.****.*****.net/OmniAppFiles -U ***app1 -W ****
Enter ***app1's password:
Domain=[***] OS=[Windows Server 2012 R2 Datacenter 9600] Server=[Windows Server 2012 R2 Datacenter 6.3]
smb: \> exit

when I use authentication-file its breaking

[root@***** _temp]# smbclient //pc-fp1.****.******.net/****AppFiles -A /var/www/html/omni/_temp/test.conf
session setup failed: NT_STATUS_LOGON_FAILURE

Thanks,
Naresh

Reply | Threaded
Open this post in threaded view
|

RE: login failures when using --authentication-file

Samba - samba-technical mailing list
Can anyone advice on this. Please?

From: Cherukuri, Naresh
Sent: Friday, October 6, 2017 11:43 AM
To: '[hidden email]'
Subject: login failures when using --authentication-file

Hello,

I am a new bee to Samba, when I tried to  login manually from my Linux server to windows server connecting successfully, but when I use authentication  file I am getting following error. Please advice?

session setup failed: NT_STATUS_LOGON_FAILURE

[root@****** _temp]# smbclient  //pc-fp1.****.*****.net/OmniAppFiles -U ***app1 -W ****
Enter ***app1's password:
Domain=[***] OS=[Windows Server 2012 R2 Datacenter 9600] Server=[Windows Server 2012 R2 Datacenter 6.3]
smb: \> exit

when I use authentication-file its breaking

[root@***** _temp]# smbclient //pc-fp1.****.******.net/****AppFiles -A /var/www/html/omni/_temp/test.conf
session setup failed: NT_STATUS_LOGON_FAILURE

Thanks,
Naresh

Reply | Threaded
Open this post in threaded view
|

Re: login failures when using --authentication-file

Samba - samba-technical mailing list
In reply to this post by Samba - samba-technical mailing list
On Fri, Oct 06, 2017 at 03:42:43PM +0000, Cherukuri, Naresh via samba-technical wrote:

> I am a new bee to Samba, when I tried to  login manually from my
> Linux server to windows server connecting successfully, but when I
> use authentication  file I am getting following error. Please
> advice?
>
> session setup failed: NT_STATUS_LOGON_FAILURE
>
> [root@****** _temp]# smbclient  //pc-fp1.****.*****.net/OmniAppFiles -U ***app1 -W ****
> Enter ***app1's password:
> Domain=[***] OS=[Windows Server 2012 R2 Datacenter 9600] Server=[Windows Server 2012 R2 Datacenter 6.3]
> smb: \> exit
>
> when I use authentication-file its breaking
>
> [root@***** _temp]# smbclient //pc-fp1.****.******.net/****AppFiles -A /var/www/html/omni/_temp/test.conf
> session setup failed: NT_STATUS_LOGON_FAILURE

Just tested with Samba master. There it works fine. What Samba version
are you using?

Volker

--
SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9
AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen
http://www.sernet.de, mailto:[hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: login failures when using --authentication-file

Samba - samba-technical mailing list
Hello Volker,

We are using samba client version on Linux machine "3.6.23". It works fine till "9/26" with the same configuration file, we are getting this problem after windows update on "9/27". Windows server version is " Windows Server 2012 R2 Datacenter 9600". You can see below screenshot for config file permissions and samba version.

File permissions:

-rw-r--r-- 1 apache apache   57 Oct  5 12:12 smb_p.conf


[root@******prod ~]# rpm -qa | grep samba
samba-winbind-clients-3.6.23-43.el6_9.x86_64
samba-client-3.6.23-43.el6_9.x86_64
samba-3.6.23-43.el6_9.x86_64
samba-winbind-3.6.23-43.el6_9.x86_64
samba-common-3.6.23-43.el6_9.x86_64


Thanks,
Naresh
-----Original Message-----
From: Volker Lendecke [mailto:[hidden email]]
Sent: Tuesday, October 10, 2017 5:05 AM
To: Cherukuri, Naresh
Cc: [hidden email]
Subject: Re: login failures when using --authentication-file

On Fri, Oct 06, 2017 at 03:42:43PM +0000, Cherukuri, Naresh via samba-technical wrote:

> I am a new bee to Samba, when I tried to  login manually from my Linux
> server to windows server connecting successfully, but when I use
> authentication  file I am getting following error. Please advice?
>
> session setup failed: NT_STATUS_LOGON_FAILURE
>
> [root@****** _temp]# smbclient  //pc-fp1.****.*****.net/OmniAppFiles
> -U ***app1 -W **** Enter ***app1's password:
> Domain=[***] OS=[Windows Server 2012 R2 Datacenter 9600]
> Server=[Windows Server 2012 R2 Datacenter 6.3]
> smb: \> exit
>
> when I use authentication-file its breaking
>
> [root@***** _temp]# smbclient //pc-fp1.****.******.net/****AppFiles -A
> /var/www/html/omni/_temp/test.conf
> session setup failed: NT_STATUS_LOGON_FAILURE

Just tested with Samba master. There it works fine. What Samba version are you using?

Volker

--
SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9 AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen http://www.sernet.de, mailto:[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: login failures when using --authentication-file

Samba - samba-technical mailing list
On Tue, Oct 10, 2017 at 01:18:33PM +0000, Cherukuri, Naresh wrote:
> We are using samba client version on Linux machine "3.6.23". It
> works fine till "9/26" with the same configuration file, we are
> getting this problem after windows update on "9/27". Windows server
> version is " Windows Server 2012 R2 Datacenter 9600". You can see
> below screenshot for config file permissions and samba version.

Please upgrade to a supported version. See

https://wiki.samba.org/index.php/Samba_Release_Planning

for a list of supported Samba releases.

From the RPM names it seems you are using RHEL. So your alternative
route is to contact RedHat and open a support case. Your third option
is to contact someone from

https://www.samba.org/samba/support/

for paid support.

With best regards,

Volker Lendecke

--
SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9
AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen
http://www.sernet.de, mailto:[hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: login failures when using --authentication-file

Samba - samba-technical mailing list
In reply to this post by Samba - samba-technical mailing list
Hai Naresh,

By default smbclient sets max protcol to NT1.

A Workaround is added the protocol to smbclient
You could try to see if you smbclient support SMB2

smbclient  //pc-fp1.****.*****.net/OmniAppFiles -U ***app1 -W -m SMB2

Or re-enable SMB1 in you Windows server again. But that opens a security leak.
But as Volker already suggested, move up to a supported samba, that is the best advice.

Greetz,

Louis



> -----Oorspronkelijk bericht-----
> Van: samba-technical
> [mailto:[hidden email]] Namens
> Cherukuri, Naresh via samba-technical
> Verzonden: dinsdag 10 oktober 2017 15:19
> Aan: [hidden email]
> CC: [hidden email]
> Onderwerp: RE: login failures when using --authentication-file
>
> Hello Volker,
>
> We are using samba client version on Linux machine "3.6.23".
> It works fine till "9/26" with the same configuration file,
> we are getting this problem after windows update on "9/27".
> Windows server version is " Windows Server 2012 R2 Datacenter
> 9600". You can see below screenshot for config file
> permissions and samba version.
>
> File permissions:
>
> -rw-r--r-- 1 apache apache   57 Oct  5 12:12 smb_p.conf
>
>
> [root@******prod ~]# rpm -qa | grep samba
> samba-winbind-clients-3.6.23-43.el6_9.x86_64
> samba-client-3.6.23-43.el6_9.x86_64
> samba-3.6.23-43.el6_9.x86_64
> samba-winbind-3.6.23-43.el6_9.x86_64
> samba-common-3.6.23-43.el6_9.x86_64
>
>
> Thanks,
> Naresh
> -----Original Message-----
> From: Volker Lendecke [mailto:[hidden email]]
> Sent: Tuesday, October 10, 2017 5:05 AM
> To: Cherukuri, Naresh
> Cc: [hidden email]
> Subject: Re: login failures when using --authentication-file
>
> On Fri, Oct 06, 2017 at 03:42:43PM +0000, Cherukuri, Naresh
> via samba-technical wrote:
> > I am a new bee to Samba, when I tried to  login manually
> from my Linux
> > server to windows server connecting successfully, but when I use
> > authentication  file I am getting following error. Please advice?
> >
> > session setup failed: NT_STATUS_LOGON_FAILURE
> >
> > [root@****** _temp]# smbclient  //pc-fp1.****.*****.net/OmniAppFiles
> > -U ***app1 -W **** Enter ***app1's password:
> > Domain=[***] OS=[Windows Server 2012 R2 Datacenter 9600]
> > Server=[Windows Server 2012 R2 Datacenter 6.3]
> > smb: \> exit
> >
> > when I use authentication-file its breaking
> >
> > [root@***** _temp]# smbclient
> //pc-fp1.****.******.net/****AppFiles -A
> > /var/www/html/omni/_temp/test.conf
> > session setup failed: NT_STATUS_LOGON_FAILURE
>
> Just tested with Samba master. There it works fine. What
> Samba version are you using?
>
> Volker
>
> --
> SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
> phone: +49-551-370000-0, fax: +49-551-370000-9 AG Göttingen,
> HRB 2816, GF: Dr. Johannes Loxen http://www.sernet.de,
> mailto:[hidden email]
>
>


Reply | Threaded
Open this post in threaded view
|

RE: login failures when using --authentication-file

Samba - samba-technical mailing list
Thank you for your suggestions. I will take it to right people who make decisions on this.

Thanks,
Naresh

-----Original Message-----
From: L.P.H. van Belle [mailto:[hidden email]]
Sent: Tuesday, October 10, 2017 10:09 AM
To: [hidden email]
Cc: Cherukuri, Naresh
Subject: RE: login failures when using --authentication-file

Hai Naresh,

By default smbclient sets max protcol to NT1.

A Workaround is added the protocol to smbclient You could try to see if you smbclient support SMB2

smbclient  //pc-fp1.****.*****.net/OmniAppFiles -U ***app1 -W -m SMB2

Or re-enable SMB1 in you Windows server again. But that opens a security leak.
But as Volker already suggested, move up to a supported samba, that is the best advice.

Greetz,

Louis



> -----Oorspronkelijk bericht-----
> Van: samba-technical
> [mailto:[hidden email]] Namens Cherukuri,
> Naresh via samba-technical
> Verzonden: dinsdag 10 oktober 2017 15:19
> Aan: [hidden email]
> CC: [hidden email]
> Onderwerp: RE: login failures when using --authentication-file
>
> Hello Volker,
>
> We are using samba client version on Linux machine "3.6.23".
> It works fine till "9/26" with the same configuration file, we are
> getting this problem after windows update on "9/27".
> Windows server version is " Windows Server 2012 R2 Datacenter 9600".
> You can see below screenshot for config file permissions and samba
> version.
>
> File permissions:
>
> -rw-r--r-- 1 apache apache   57 Oct  5 12:12 smb_p.conf
>
>
> [root@******prod ~]# rpm -qa | grep samba
> samba-winbind-clients-3.6.23-43.el6_9.x86_64
> samba-client-3.6.23-43.el6_9.x86_64
> samba-3.6.23-43.el6_9.x86_64
> samba-winbind-3.6.23-43.el6_9.x86_64
> samba-common-3.6.23-43.el6_9.x86_64
>
>
> Thanks,
> Naresh
> -----Original Message-----
> From: Volker Lendecke [mailto:[hidden email]]
> Sent: Tuesday, October 10, 2017 5:05 AM
> To: Cherukuri, Naresh
> Cc: [hidden email]
> Subject: Re: login failures when using --authentication-file
>
> On Fri, Oct 06, 2017 at 03:42:43PM +0000, Cherukuri, Naresh via
> samba-technical wrote:
> > I am a new bee to Samba, when I tried to  login manually
> from my Linux
> > server to windows server connecting successfully, but when I use
> > authentication  file I am getting following error. Please advice?
> >
> > session setup failed: NT_STATUS_LOGON_FAILURE
> >
> > [root@****** _temp]# smbclient  //pc-fp1.****.*****.net/OmniAppFiles
> > -U ***app1 -W **** Enter ***app1's password:
> > Domain=[***] OS=[Windows Server 2012 R2 Datacenter 9600]
> > Server=[Windows Server 2012 R2 Datacenter 6.3]
> > smb: \> exit
> >
> > when I use authentication-file its breaking
> >
> > [root@***** _temp]# smbclient
> //pc-fp1.****.******.net/****AppFiles -A
> > /var/www/html/omni/_temp/test.conf
> > session setup failed: NT_STATUS_LOGON_FAILURE
>
> Just tested with Samba master. There it works fine. What Samba version
> are you using?
>
> Volker
>
> --
> SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
> phone: +49-551-370000-0, fax: +49-551-370000-9 AG Göttingen, HRB 2816,
> GF: Dr. Johannes Loxen http://www.sernet.de, mailto:[hidden email]
>
>