jCIFS on OpenVMS 7.3-2?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

jCIFS on OpenVMS 7.3-2?

dave.mcneil
Hello all,

I have an OpenVMS 7.3-2 system with Java 1.4.2 (Java(TM) 2 Runtime
Environment, Standard Edition ) and Apache/Tomcat 5.5.9.  I downloaded
the jcifs_1.2.9.jar file and put it in
Catalina_home:[common.lib]jcifs_1_2_9.jar.  When Tomcat starts up it
complains thus:

Jul 10, 2006 3:50:35 PM org.apache.catalina.startup.TldConfig tldScanJar
SEVERE: Exception processing JAR at resource path
/kawc09$dra0/apache/jakarta/tomcat/common/lib/jcifs_1_2_9.jar in context

java.util.zip.ZipException: error in opening zip file
[stack trace removed]

It shows the same error for every application that it loads.

So, I re-downloaded jar file and redeployed it with the same result.  I
can execute " jar -tvf catalina_home:[common.lib]jcifs_1_2_9.jar" and I
see all the classes that I expect, so I don't understand why Tomcat is
complaining when it starts.

I tried downloading the source to rebuild it, but when I enter "
@ide$ant_home:ide_ant "jar" " it fails the dependency test, complaining
that the Java Servlet API classes could not be found.  But I see them in
Catalina_home:[common.lib]servlet-api.jar.

Does anyone here have jCIFS running on the OpenVMS 7.3-2 system?

Dave



Reply | Threaded
Open this post in threaded view
|

Re: jCIFS on OpenVMS 7.3-2?

Michael B Allen-4
On Thu, 13 Jul 2006 11:56:31 -0400
<[hidden email]> wrote:

> Hello all,
>
> I have an OpenVMS 7.3-2 system with Java 1.4.2 (Java(TM) 2 Runtime
> Environment, Standard Edition ) and Apache/Tomcat 5.5.9.  I downloaded
> the jcifs_1.2.9.jar file and put it in
> Catalina_home:[common.lib]jcifs_1_2_9.jar.  When Tomcat starts up it
> complains thus:
>
> Jul 10, 2006 3:50:35 PM org.apache.catalina.startup.TldConfig tldScanJar
> SEVERE: Exception processing JAR at resource path
> /kawc09$dra0/apache/jakarta/tomcat/common/lib/jcifs_1_2_9.jar in context
>
> java.util.zip.ZipException: error in opening zip file
> [stack trace removed]
>
> It shows the same error for every application that it loads.
>
> So, I re-downloaded jar file and redeployed it with the same result.  I
> can execute " jar -tvf catalina_home:[common.lib]jcifs_1_2_9.jar" and I
> see all the classes that I expect, so I don't understand why Tomcat is
> complaining when it starts.
>
> I tried downloading the source to rebuild it, but when I enter "
> @ide$ant_home:ide_ant "jar" " it fails the dependency test, complaining
> that the Java Servlet API classes could not be found.  But I see them in
> Catalina_home:[common.lib]servlet-api.jar.

Add that jar to your classpath (or just temporarily copy it to the
directory in which your building the jar).

Or extract the jar and rebuild it with the local jar tool. It's probably
some kind of bug in the VM one of us is using.

> Does anyone here have jCIFS running on the OpenVMS 7.3-2 system?

I can't confirm that.

Mike

--
Michael B Allen
PHP Extension for SSO w/ Windows Group Authorization
http://www.ioplex.com/