groups DOMAIN+user doesn't work

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

groups DOMAIN+user doesn't work

Nerijus Baliunas
Hello,

I am using winbind (samba 3.0.11).
A command "groups DOMAIN+user" doesn't work for some users:

# groups DOMAIN+user1
id: cannot find name for group ID 10073

# groups DOMAIN+user2  
DOMAIN+user2 : DOMAIN+domain users DOMAIN+apskaita

# getent passwd DOMAIN+user1
DOMAIN+user1:*:10042:10000:xxx:/home/DOMAIN/user1:/bin/false

# getent passwd DOMAIN+user2
DOMAIN+user2:*:10109:10000:xxx:/home/DOMAIN/user2:/bin/false

# getent group
...
DOMAIN+domain users:x:10000:
...
BUILTIN+users:x:10073:

>From winbindd.log:
nsswitch/winbindd_group.c:winbindd_getgrgid(400)
  name 'Users' is not a local or domain group: 5

Because of this problem group permissions for such users (like user1)
do not work.

Regards,
Nerijus
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba
Reply | Threaded
Open this post in threaded view
|

Re: groups DOMAIN+user doesn't work

Nerijus Baliunas
On Wed, 27 Apr 2005 00:12:56 +0300 (EEST) Nerijus Baliunas <[hidden email]> wrote:

> >From winbindd.log:
> nsswitch/winbindd_group.c:winbindd_getgrgid(400)
>   name 'Users' is not a local or domain group: 5
>
> Because of this problem group permissions for such users (like user1)
> do not work.

Actually one more error in winbindd.log:

nsswitch/winbindd_group.c:winbindd_getgrnam(308)
  name 'users' is not a local or domain group: 5

Any ideas? Why winbind tries to map local (BUILTIN) group?

Regards,
Nerijus
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba
Reply | Threaded
Open this post in threaded view
|

Re: groups DOMAIN+user doesn't work

Nerijus Baliunas
In reply to this post by Nerijus Baliunas
Hello,

I see in 3.0.15pre2 relnotes:
     Fix checks for matching groups in an file ACL against the
     user's primary and supplementary group list.

In 3.0.13:
     BUG 2521: Fix error in access checks when user group ACLs.

Could it be one of these fixes my problem?

On Wed, 27 Apr 2005 00:12:56 +0300 (EEST) Nerijus Baliunas <[hidden email]> wrote:

> Hello,
>
> I am using winbind (samba 3.0.11).
> A command "groups DOMAIN+user" doesn't work for some users:
>
> # groups DOMAIN+user1
> id: cannot find name for group ID 10073
>
> # groups DOMAIN+user2  
> DOMAIN+user2 : DOMAIN+domain users DOMAIN+apskaita
>
> # getent passwd DOMAIN+user1
> DOMAIN+user1:*:10042:10000:xxx:/home/DOMAIN/user1:/bin/false
>
> # getent passwd DOMAIN+user2
> DOMAIN+user2:*:10109:10000:xxx:/home/DOMAIN/user2:/bin/false
>
> # getent group
> ...
> DOMAIN+domain users:x:10000:
> ...
> BUILTIN+users:x:10073:
>
> >From winbindd.log:
> nsswitch/winbindd_group.c:winbindd_getgrgid(400)
>   name 'Users' is not a local or domain group: 5
>
> Because of this problem group permissions for such users (like user1)
> do not work.
>
> Regards,
> Nerijus

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba