compiling samba 4.7.1 on centos 7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

compiling samba 4.7.1 on centos 7

Samba - General mailing list
Hello,

I am trying to compile an rpm of samba 4.7.1 on centos 7.  I have everything compiling but the problem is when I go to install the rpms, yum complains that samba-python requires libdnsserver-common-samba4.so. That file is part of samba-dc-libs which I believe doesn't work on centos 7 due to incompatibility with mit-kerberos. Does anyone know if there is a way to build this file without building samba-dc? Alternatively can I patch samba-python to not use libdnsserver-common-samba4.so?

Thanks for any help
Dylan


This e-mail message and all attachments transmitted with it may contain privileged and/or confidential information intended solely for the use of the addressee(s). If the reader of this message is not the intended recipient, you are hereby notified that any reading, dissemination, distribution, copying, forwarding or other use of this message or its attachments is strictly prohibited. If you have received this message in error, please notify the sender immediately and delete this message, all attachments and all copies and backups thereof.
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: compiling samba 4.7.1 on centos 7

Samba - General mailing list
If anyone has any info on this it would be really helpful.

Also, it looks like centos 7.4 has krb5 1.15.1. If I build with samba-dc turned on, will that be okay as the krb5 version is new enough?
________________________________
From: samba <[hidden email]> on behalf of Dylan Stephano-Shachter via samba <[hidden email]>
Sent: Sunday, November 12, 2017 11:31:20 PM
To: [hidden email]
Subject: [Samba] compiling samba 4.7.1 on centos 7

Hello,

I am trying to compile an rpm of samba 4.7.1 on centos 7.  I have everything compiling but the problem is when I go to install the rpms, yum complains that samba-python requires libdnsserver-common-samba4.so. That file is part of samba-dc-libs which I believe doesn't work on centos 7 due to incompatibility with mit-kerberos. Does anyone know if there is a way to build this file without building samba-dc? Alternatively can I patch samba-python to not use libdnsserver-common-samba4.so?

Thanks for any help
Dylan


This e-mail message and all attachments transmitted with it may contain privileged and/or confidential information intended solely for the use of the addressee(s). If the reader of this message is not the intended recipient, you are hereby notified that any reading, dissemination, distribution, copying, forwarding or other use of this message or its attachments is strictly prohibited. If you have received this message in error, please notify the sender immediately and delete this message, all attachments and all copies and backups thereof.
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
This e-mail message and all attachments transmitted with it may contain privileged and/or confidential information intended solely for the use of the addressee(s). If the reader of this message is not the intended recipient, you are hereby notified that any reading, dissemination, distribution, copying, forwarding or other use of this message or its attachments is strictly prohibited. If you have received this message in error, please notify the sender immediately and delete this message, all attachments and all copies and backups thereof.
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|

Re: compiling samba 4.7.1 on centos 7

Samba - General mailing list
On Wed, 15 Nov 2017, Dylan Stephano-Shachter via samba wrote:

> If anyone has any info on this it would be really helpful.
>
> Also, it looks like centos 7.4 has krb5 1.15.1. If I build with samba-dc turned on, will that be okay as the krb5 version is new enough?

While I cannot speak to your rpm dep problem I can tell you that
krb5-libs-1.15.1-8.el7.x86_64 and friends work just fine on a self compiled
AD DC using Ansible to manage the build and install.

If you actually get the rpms to work I would be interested in looking at the
src.rpm.

HTH,

--
Tom [hidden email]


> ________________________________
> From: samba <[hidden email]> on behalf of Dylan Stephano-Shachter via samba <[hidden email]>
> Sent: Sunday, November 12, 2017 11:31:20 PM
> To: [hidden email]
> Subject: [Samba] compiling samba 4.7.1 on centos 7
>
> Hello,
>
> I am trying to compile an rpm of samba 4.7.1 on centos 7.  I have everything compiling but the problem is when I go to install the rpms, yum complains that samba-python requires libdnsserver-common-samba4.so. That file is part of samba-dc-libs which I believe doesn't work on centos 7 due to incompatibility with mit-kerberos. Does anyone know if there is a way to build this file without building samba-dc? Alternatively can I patch samba-python to not use libdnsserver-common-samba4.so?
>
> Thanks for any help
> Dylan
>
>
> This e-mail message and all attachments transmitted with it may contain privileged and/or confidential information intended solely for the use of the addressee(s). If the reader of this message is not the intended recipient, you are hereby notified that any reading, dissemination, distribution, copying, forwarding or other use of this message or its attachments is strictly prohibited. If you have received this message in error, please notify the sender immediately and delete this message, all attachments and all copies and backups thereof.
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> This e-mail message and all attachments transmitted with it may contain privileged and/or confidential information intended solely for the use of the addressee(s). If the reader of this message is not the intended recipient, you are hereby notified that any reading, dissemination, distribution, copying, forwarding or other use of this message or its attachments is strictly prohibited. If you have received this message in error, please notify the sender immediately and delete this message, all attachments and all copies and backups thereof.
>

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba