Upgrading from Samba 3.07 to 3.010 on different box

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrading from Samba 3.07 to 3.010 on different box

Wayne Dozier (Greensboro College)
K, here is my situation. I have 2 servers. The original which is running
3.07 on one server. It has been running for some time and is our PDC. I have
another server that I have installed Samba 3.010. This will be the PDC and
the other box will be taken out of commission. I moved over all the data and
accounts. Got Samba up and running with the same config. Downed the original
server and brought this server up. My problem is, none of my XP machines
will log into the Server. I removed an XP machine from the domain and added
it to a workgroup, then re-added it to the domain and it worked fine. This
is a PDC in a College environment so going around and touching every machine
to re-add to the domain is not a solution i want to think about.

My question is, what do I have to do to avoid doing this? I was wondering if
this has something to do with the server SSID? If so, how do I go about
moving that? Any help would be greatly appreciated.

--
Wayne Dozier
Network Administrator
Greensboro College
336-272-7102 ext 594
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading from Samba 3.07 to 3.010 on different box

Wayne Dozier (Greensboro College)
k, I assumed it has something to do with the SID.

So I ran

# net getlocalsid

on the old server, used the output and ran:

# net setlocalsid (output from original server)

rebooted and it seems to have kept the new SID

Is this the only thing that should need to be changed?

Or is the problem somewhere else?

Thanks again for any help.

Wayne


On 4/25/05, Wayne Dozier (Greensboro College) <[hidden email]> wrote:

>
> K, here is my situation. I have 2 servers. The original which is running
> 3.07 on one server. It has been running for some time and is our PDC. I
> have another server that I have installed Samba 3.010. This will be the
> PDC and the other box will be taken out of commission. I moved over all the
> data and accounts. Got Samba up and running with the same config. Downed the
> original server and brought this server up. My problem is, none of my XP
> machines will log into the Server. I removed an XP machine from the domain
> and added it to a workgroup, then re-added it to the domain and it worked
> fine. This is a PDC in a College environment so going around and touching
> every machine to re-add to the domain is not a solution i want to think
> about.
>
> My question is, what do I have to do to avoid doing this? I was wondering
> if this has something to do with the server SSID? If so, how do I go about
> moving that? Any help would be greatly appreciated.
>
> --
> Wayne Dozier
> Network Administrator
> Greensboro College
> 336-272-7102 ext 594
>



--
Wayne Dozier
Network Administrator
Greensboro College
336-272-7102 ext 594
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba