Updating to Samba-4.6.0 testparm ERROR: Invalid idmap range for domain *!

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Updating to Samba-4.6.0 testparm ERROR: Invalid idmap range for domain *!

Samba - General mailing list
After updating my test AD DC from samba version 4.5.5 to 4.6.0 and running testparm as asvised, I get the error

idmap range not specified for domain '*'
ERROR: Invalid idmap range for domain *!

After I get trhe dump of the service definitions, I notice that there is a line in the [global] section:

        idmap config * : backend - tdb

However, my smb.conf doesn't contain any such line (as recommended by the Wiki documentation) so where is this coming from, and what
to do about it?

Thanks,

Roy


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Updating to Samba-4.6.0 testparm ERROR: Invalid idmap range for domain *!

Samba - General mailing list
On Thu, 16 Mar 2017 18:15:10 +0000
spindles7 via samba <[hidden email]> wrote:

> After updating my test AD DC from samba version 4.5.5 to 4.6.0 and
> running testparm as asvised, I get the error
>
> idmap range not specified for domain '*'
> ERROR: Invalid idmap range for domain *!
>
> After I get trhe dump of the service definitions, I notice that there
> is a line in the [global] section:
>
> idmap config * : backend - tdb
>
> However, my smb.conf doesn't contain any such line (as recommended by
> the Wiki documentation) so where is this coming from, and what to do
> about it?
>

This is an artefact of the latest changes and you do have the line ;-)
try running 'testparm -v'

There is a bug report about the problem here:

https://bugzilla.samba.org/show_bug.cgi?id=12629

Rowland

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Updating to Samba-4.6.0 testparm ERROR: Invalid idmap range for domain *!

Samba - General mailing list
Thanks, Rowland.

On Thu, 16 Mar 2017 18:38:28 +0000, Rowland Penny via samba <[hidden email]> wrote:

>On Thu, 16 Mar 2017 18:15:10 +0000
>spindles7 via samba <[hidden email]> wrote:
>
>> After updating my test AD DC from samba version 4.5.5 to 4.6.0 and
>> running testparm as asvised, I get the error
>>
>> idmap range not specified for domain '*'
>> ERROR: Invalid idmap range for domain *!
>>
>> After I get trhe dump of the service definitions, I notice that there
>> is a line in the [global] section:
>>
>> idmap config * : backend - tdb
>>
>> However, my smb.conf doesn't contain any such line (as recommended by
>> the Wiki documentation) so where is this coming from, and what to do
>> about it?
>>
>
>This is an artefact of the latest changes and you do have the line ;-)
>try running 'testparm -v'
>
>There is a bug report about the problem here:
>
>https://bugzilla.samba.org/show_bug.cgi?id=12629
>
>Rowland


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Loading...