Support SMB v2.1+

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Support SMB v2.1+

Mustaque
This post has NOT been accepted by the mailing list yet.
We have been using JCIFS in our product. We need to upgrade to SMB 2.1+ soon. I have couple of quick questions regarding that :

1. Since SMB-v1.0 has some security issues (wannacry attack), does you or your team are planning to implement SMB v.2.1 or above anytime soon?

2. If we want to upgrade/patch JCIFS to support SMB v2.1 or above, what part of the code in JCIFS package we should mostly focus on.
   
   
I would really appreciate your help. We are sincerely planning to make JCIFS support SMB v.2.1 or above.
   
I am looking forward to hearing from you soon.
   
   
Thanks.
Mustaque
Loading...