Quantcast

Server is working, but "getpeername" log errors still appearing

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Server is working, but "getpeername" log errors still appearing

Luiz Alfredo Baggiotto
Hello experts

After a total panic last weekend, now my LDAP+Samba is working fine,
apparently. However, in my syslog, each one minute, still occurring
errors like this:

Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:set_socket_options(202)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]   Failed
to set socket option SO_KEEPALIVE (Error Invalid argument)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:set_socket_options(202)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]   Failed
to set socket option TCP_NODELAY (Error Invalid argument)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:get_peer_addr(1150)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
getpeername failed. Error was Transport endpoint is not connected
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:get_peer_addr(1150)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
getpeername failed. Error was Transport endpoint is not connected
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/access.c:check_access(328)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:get_peer_addr(1150)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
getpeername failed. Error was Transport endpoint is not connected
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]   Denied
connection from  (0.0.0.0)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:get_peer_addr(1150)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
getpeername failed. Error was Transport endpoint is not connected
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
Connection denied from 0.0.0.0
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:write_socket_data(430)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
write_socket_data: write failure. Error = Broken pipe
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:write_socket(455)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
write_socket: Error writing 5 bytes to socket 5: ERRNO = Broken pipe
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]
[2005/04/25 08:47:21, 0] lib/util_sock.c:send_smb(647)
Apr 25 08:47:21 myserver smbd[10245]: [ID 702911 daemon.error]   Error
writing 5 bytes to client. -1. (Broken pipe)

Eventually, it occurs also something like this:

Apr 25 08:31:16 myserver smbd[22931]: [ID 510469 daemon.error] nss_ldap:
could not get LDAP result - Can't contact LDAP server

Are there some way to solve it? I tried, without results, to set this
options in smb.conf:

        keep alive = 60
        smb ports = 445 139
        use sendfile = no

Thanks in advance for your attention.

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba
Loading...