Quantcast

Samba shows error NT Status: STATUS_OBJECT_NAME_NOT_FOUND when copying 10GB file using robocopy when ecryptfs file system shared using samba

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Samba shows error NT Status: STATUS_OBJECT_NAME_NOT_FOUND when copying 10GB file using robocopy when ecryptfs file system shared using samba

Samba - General mailing list
I shared raid 5 array which is mounted using ecryptfs to a windows 10 client using samba share . When i do a robocopy of file greater than size of 7GB the samba throws an error NT Status: STATUS_OBJECT_NAME_NOT_FOUND which can be observed in wire shark .


Setup :

----------

Host with ubuntu 16.01  -------------------> windows 10 client

(Samba server,                                                     (robocopy)

  Raid 5 with ecryptfs )



On ubuntu server :

--------------------------

kernel - 4.9.0

samba version -  4.1.6-Ubuntu

  *   Created RAID 5 Array with 5 devices .
  *   # mdadm --create --assume-clean --verbose /dev/md5 --level=5 --raid-devices=5 /dev/sdb1 /dev/sdc1 /dev/sdd1 /dev/sde1 /dev/sdf1
  *   # mkfs.ext4  -b 32768 /dev/md5
  *   # mount /dev/md5 /home/test/raid_5
  *   Created samba password for test user
     *   # smbpasswd -a test
  *   Created directories needed to be shared .
     *   mkdir /home/test/raid_5/flow1
     *   mkdir /home/test/raid_5/flow2
  *   Created ecryptfs of the directories to be shared .
  *
ot@arm64:/home/test/raid_5# mount -t ecryptfs flow2/ flow2/
Passphrase:
Select cipher:
 1) aes: blocksize = 16; min keysize = 16; max keysize = 32
 2) blowfish: blocksize = 8; min keysize = 16; max keysize = 56
 3) des3_ede: blocksize = 8; min keysize = 24; max keysize = 24
 4) twofish: blocksize = 16; min keysize = 16; max keysize = 32
 5) cast6: blocksize = 16; min keysize = 16; max keysize = 32
 6) cast5: blocksize = 8; min keysize = 5; max keysize = 16
Selection [aes]: aes
Select key bytes:
 1) 16
 2) 32
 3) 24
Selection [16]:
Enable plaintext passthrough (y/n) [n]: n
Enable filename encryption (y/n) [n]: n
Attempting to mount with the following options:
  ecryptfs_unlink_sigs
  ecryptfs_key_bytes=16
  ecryptfs_cipher=aes
  ecryptfs_sig=29acec13662d2e8f
Mounted eCryptfs
  *
  *   Start the samba service
  *   # /etc/init.d/samba start

On windows 10 Client .
-------------------------------

  *   Connected to network device of the ubuntu host
  *   Ran robocopy of file 10GB to the network share
  *
C:\Users\machine-412>robocopy  E:\ Z:\ 10G.tst

-------------------------------------------------------------------------------
   ROBOCOPY     ::     Robust File Copy for Windows
-------------------------------------------------------------------------------

  Started : Thursday, May 11, 2017 12:33:17 PM
   Source : E:\
     Dest : Z:\

    Files : 10G.tst

  Options : /DCOPY:DA /COPY:DAT /R:1000000 /W:30

------------------------------------------------------------------------------

                           1    E:\
  0.0%      New File              10.0 g        10G.tst
2017/05/11 12:34:22 ERROR 59 (0x0000003B) Copying File E:\10G.tst
An unexpected network error occurred.
Waiting 30 seconds... Retrying...
  0.0%      New File              10.0 g        10G.tst
  *
  *   I get  the above error and it just retries to copy .
  *   This is seen only when  copying files greater than 7GB .

  *

On Wireshark the Samba throws the error STATUS_OBJECT_NAME_NOT_FOUND.

My smb.conf is as below .
[global]
        #socket options = TCP_NODELAY
        max xmit = 65535
        paranoid server security = No
        socket options = IPTOS_LOWDELAY TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF=524288 SO_RCVBUF=524288
        allocation roundup size = 0
        max log size = 50
        min receivefile size = 1
        use sendfile = yes
        use sendfile = Yes
        read raw = yes
        write raw = yes
        dead time = 15
        block size = 65535
        log level = 0
        encrypt passwords = yes
        create mask = 0777
        directory mask = 0777
        null passwords = yes
        ;map to guest = bad user
        guest account = root
        passdb backend = smbpasswd
        include = /etc/samba/include_workgroup.conf
        ;server multi channel support = yes
[raid_51]
       comment = Home Directories
       browseable = yes
       writable = yes
       map read only = no
       guest ok = no
       path = /home/test/raid_5/flow1/
       public = yes
       large readwrite = yes
       use sendfile = yes
[raid_52]
       comment = Home Directories
       browseable = yes
       writable = yes
       map read only = no
       guest ok = no
       path = /home/test/raid_5/flow2/
       public = yes
       large readwrite = yes
       use sendfile = yes


Is there any configuration i need  to use in smb.conf while using ecryptfs.

Regards,
Anil

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba
Loading...