[Bug 12489] New: --fuzzy --fuzzy does not work with daemon

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 12489] New: --fuzzy --fuzzy does not work with daemon

samba-bugs
https://bugzilla.samba.org/show_bug.cgi?id=12489

            Bug ID: 12489
           Summary: --fuzzy --fuzzy does not work with daemon
           Product: rsync
           Version: 3.1.2
          Hardware: All
                OS: All
            Status: NEW
          Severity: critical
          Priority: P5
         Component: core
          Assignee: [hidden email]
          Reporter: [hidden email]
        QA Contact: [hidden email]

Hello,

I try to use --fuzzy --fuzzy with --link-dest :
rsync -aR -yy --link-dest="../2016-12-28/" --link-dest="../2016-12-27/"
/my/folder srv::daemon/computer/2016-12-29/

But :
--fuzzy --fuzzy eligible files are not detected (--debug=FUZZY2 gives nothing
at all).

Files are correctly linked, but for every file, rsync daemon logs the following
:
file has vanished: "/computer/2016-12-29/2016-12-28/my/folder/file"
file has vanished: "/computer/2016-12-29/2016-12-27/my/folder/file"

I tried with the following command :
rsync -aR -yy --link-dest="/computer/2016-12-28/"
--link-dest="/computer/2016-12-27/" /my/folder srv::daemon/computer/2016-12-29/

Which gives :
file has vanished:
"/computer/2016-12-29/srvpath/computer/2016-12-28/my/folder/file"
file has vanished:
"/computer/2016-12-29/srvpath/computer/2016-12-27/my/folder/file"

I don't have these error messages with only one --fuzzy.

I don't have the problem using a SSH server as the target instead of a Rsync
daemon.

And I don't have the problem setting chroot to yes in the Rsync daemon.

So sounds like these are related to --fuzzy --fuzzy talking to a Rsync daemon
with chroot=no.

Tested in several environments, with Rsync 3.1.1 and 3.1.2.

I'm also surprised that, according to these log lines, --fuzzy --fuzzy tries to
reach every file in link-dest directories, even if they are absolutely not
needed (simple test with destination already in-sync, or with all destination
files to be simply linked (same name/date/perms etc...)).

Thank you for your support !

Best regards,

Ben

--
You are receiving this mail because:
You are the QA Contact for the bug.

--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html
Reply | Threaded
Open this post in threaded view
|

[Bug 12489] --fuzzy --fuzzy does not work with daemon

samba-bugs
https://bugzilla.samba.org/show_bug.cgi?id=12489

Ben RUBSON <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|critical                    |normal

--- Comment #1 from Ben RUBSON <[hidden email]> ---
As a workaround I found a way to enable "use chroot = yes" in my production
modules.
I then put the Importance of this bug report back to "normal", but keep it
opened as the issue is real :)

--
You are receiving this mail because:
You are the QA Contact for the bug.

--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html