Aw: Strange dry-run problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Aw: Strange dry-run problem

devzero
is it still reproducible after a fresh boot? no stale nfs or fuse mounts or similar?
--
Diese Nachricht wurde von meinem Android Mobiltelefon mit WEB.DE Mail gesendet.
Am 06.08.2016, 00:52, Tom Horsley <[hidden email]> schrieb:
I was working on a backup script today and doing lots
of runs with the --dry-run option to make sure I
had things the way I wanted them.

One particular filesystem I was backing up always
hung right as it should have been finished. (This
happened every time I did a dry run, it was 100%
reproducible). Several other filesystems I was
backing up had no problems of any kind with the
dry run using the same command with different
source and dest directories (and exclude lists).

Checking all the rsync processes (this was a local
file to local file rsync, so everything was on the
same system), I found all 3 rsync processes sitting
in a select() call, and none of them had any files
open, just a couple of sockets and stdout showed up in
the /proc/pid/fd directories.

I added a --timeout=300 option, and that at least
made it exit after 5 minutes.

Later, when I removed the --dry-run option and
did the real backup, the same filesystem caused
no problems at all. No hang, all the backups
copied OK, no errors of any kind.

I just thought it was weird enough to report,
but I'm unlikely to have any time to do any debugging.
Just wanted to get it on record in case someone else
sees it.

This was on a centos 7.0 system, and I updated
rsync on it just in case that fixed it, but the
problem continued even after the yum update.

--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html

--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html
Reply | Threaded
Open this post in threaded view
|

Re: Strange dry-run problem

Tom Horsley
On Sat, 6 Aug 2016 11:21:26 +0200
[hidden email] wrote:

> is it still reproducible after a fresh boot? no stale nfs or fuse mounts or similar?

I didn't reboot, but I did check that I could 'ls' all the
NFS mounts (all of which were in my exclusion list anyway).
And if it was hung in a stat(), I wouldn't think that
strace would have showed all 3 processes sitting in select().

Plus, of course, there was no hang when I removed
the --dry-run option and did the real backup :-).

--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html